Question: Are there special steps necessary to  install Ephesoft on Ubuntu 14.10?

 

Answer: Like Ubuntu 14.04, Ubuntu 14.10 is supported by Ephesoft with some minor steps to take before installing Ephesoft. Please take a look here.

Before attempting an install of Ephesoft on Ubuntu 14.10, the user must first install MySQL Server and change the root password for MySQL as this will be needed during the install of Ephesoft.

Here are the steps used to install MySQL Server on Ubuntu 14.10 before installing Ephesoft.

sudo apt-get install mysql-server

-click ok when it asks you to agree to the license

-enter your root password for mysql when asked. (you will need this during the Ephesoft install)

 

Edit the install script: (difficulty HIGH)

1. Open the file install-helper

2. Search for the following command in the install-helper: ‘service mysqld start’ and replace it with ‘/etc/init.d/mysql start’

3. Search for the following command in the install-helper: ‘service mysqld restart’ and replace it with ‘/etc/init.d/mysql restart’

 

Edit the dependencies:

Follow these instructions only if you have not attempted to install Ephesoft on Ubuntu 14.10 yet.

1. You will need to edit a file inside of the Ephesoft_3.1.2.3.tar.gz file.

2. Open the file in archive manager

3. Navigate to Ephesoft/Dependencies in archive manager

4. Open the File dependencies_ubuntu in gedit or your favorite text editor

5. change the value listed from libtiff4-dev to libtiff5-dev. Leave the =0 after this entry

6. A popup message will come up from Archive Manager asking ‘Update the file “dependencies_ubuntu” in the archive “Ephesoft_3.1.2.3.tar.gz”‘. Click update button

7. Close archive manager

8. proceed with install of Ephesoft on Ubuntu 14.10

9. If you receive an error message stating that libtiff4-dev is not available, follow the steps below.

 

Follow these instructions if you have tried installing Ephesoft on Ubuntu 14.10 but receive an error reporting that libtiff4-dev is not available.

1. open the file /opt/Ephesoft/Dependencies/dependencies in your text editor

2. change the value listed from libtiff4-dev to libtiff5-dev. Leave the =0 after this entry

3. re-attempt install of ephesoft as before

Follow the link below for “Linux Catalina.out gets too big to Open in Text Editors” issue

Click this link for reference!

Was this article helpful to you?

J.D. Abbey

Comments are closed.