Affected Version: 4501

Component: Upgrade failure

Issue Description:

If you are upgrading from Ephesoft Transact 4500 to 4501 on Linux and you are seeing upgrade failing due to nuance unable to upgrade and below exception:

========== Upgrading Nuance ==========
Extracting the tar file for Nuance. Please wait…
Nuance/
Nuance/Debian/
Nuance/Debian/20.2.0/
Nuance/Debian/20.2.0/nuance-omnipage-csdk-20.2-17465.100/
Nuance/Debian/20.2.0/nuance-omnipage-csdk-20.2-17465.100/LICENSE
Nuance/Debian/20.2.0/nuance-omnipage-csdk-20.2-17465.100/nuance-omnipage-csdk-lib64_20.2-17465.100_amd64.deb
Nuance/Debian/20.2.0/nuance-omnipage-csdk-20.2-17465.100/nuance-omnipage-csdk-lib64_20.2-17465.100_amd64.deb.asc
Nuance/Debian/20.2.0/nuance-omnipage-csdk-20.2-17465.100/README
Nuance/gpg-pubkey-nuance-lnx1.asc
Nuance/lcxz
Nuance/lcxz.h
Nuance/RedHat/
Nuance/RedHat/20.2.0/
Nuance/RedHat/20.2.0/nuance-omnipage-csdk-20.2-17465.100/
Nuance/RedHat/20.2.0/nuance-omnipage-csdk-20.2-17465.100/LICENSE
Nuance/RedHat/20.2.0/nuance-omnipage-csdk-20.2-17465.100/nuance-omnipage-csdk-lib64-20.2-17465.100.x86_64.rpm
Nuance/RedHat/20.2.0/nuance-omnipage-csdk-20.2-17465.100/README
Importing the Nuance public key. Please wait…
Nuance public key imported successfully.
Installing binaries for Nuance. Please wait…
error: Failed dependencies:
libc.so.6(GLIBC_2.14)(64bit) is needed by nuance-omnipage-csdk-lib64-20.2-17465.100.x86_64
libc.so.6(GLIBC_2.15)(64bit) is needed by nuance-omnipage-csdk-lib64-20.2-17465.100.x86_64
libc.so.6(GLIBC_2.16)(64bit) is needed by nuance-omnipage-csdk-lib64-20.2-17465.100.x86_64
License information found in the backup. So reverting back up license information.
Deleting temp file /opt/Ephesoft/temp-ephesoft-20180531135320

 

Reason for upgrade failure:

From Ephesoft 4501 there are certain limitations with Nuance where the ephesoft installer is packaged with Nuance 20.02 version and it has now only compatibility for CentOS and RHEL for their 7+ version and not on 6.x versions.

If you are on CentOS 6.x or RHEL 6.x version then there is no way you can upgrade to 4501 and higher versions.

Please go through supported platforms for 4501 wiki article here for more information

Was this article helpful to you?

Abhishek Jain